View Issue Details

IDProjectCategoryView StatusLast Update
0000871GT-MP ClientAPIpublic2018-01-13 21:51
ReporterSilverdarkAssigned Toroot 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionduplicate 
Product Version0.1.6 
Target VersionFixed in Version 
Summary0000871: Client onPlayerEnterVehicle seat returns wrong value for some vehicles
DescriptionFor some vehicles the onPlayerEnterVehicle seat parameter has a wrong value
Steps To ReproduceCode:

API.onPlayerEnterVehicle.connect((handle, seat) =>
{
    API.sendChatMessage(`Client: ${seat} - API Call: ${API.getPlayerVehicleSeat(API.getLocalPlayer())}`);
});

Enter XA-21 as driver:
Output: "Client: -3 - API Call: -1
TagsNo tags attached.

Relationships

duplicate of 0000751 resolvedDurtyFree None seat when entering as driver (onPlayerEnterVehicle) 

Activities

Anony

2018-01-11 22:53

reporter   ~0001280

It's fixed in upcoming update (https://bug.gt-mp.net/view.php?id=751)

Silverdark

2018-01-12 17:26

reporter   ~0001282

oh, sorry. Can be closed

Issue History

Date Modified Username Field Change
2018-01-11 21:02 Silverdark New Issue
2018-01-11 22:53 Anony Note Added: 0001280
2018-01-12 17:26 Silverdark Note Added: 0001282
2018-01-13 21:51 root Assigned To => root
2018-01-13 21:51 root Status new => closed
2018-01-13 21:51 root Resolution open => duplicate
2018-01-13 21:51 root Relationship added duplicate of 0000751