View Issue Details

IDProjectCategoryView StatusLast Update
0000865GT-MP ClientStabilitypublic2018-01-10 16:01
ReporterrootcauseAssigned ToDurtyFree 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000865: [0.1.7] reviveLocalPlayer and disconnecting
DescriptionIf you use API.reviveLocalPlayer(false) inside onPlayerDeath, they won't be revived. (This part works as intended, 10/10)

The problem is, since they are never revived, they stay dead even after they disconnect & join another server/rejoin the same server.

Video: https://youtu.be/qJGjyKrBFoc
Steps To Reproduce- Join test server that has disable reviving script
- Die
- Disconnect
- Join another server or reconnect
- Your character will just collapse
Additional InformationDisable reviving script(clientside):

API.onPlayerDeath.connect(function(killer, weapon) {
    API.reviveLocalPlayer(false);
});
Tags0.1.7

Activities

DurtyFree

2018-01-10 16:01

administrator   ~0001276

Fixed thanks

Issue History

Date Modified Username Field Change
2018-01-08 11:22 rootcause New Issue
2018-01-08 11:22 rootcause Tag Attached: 0.1.7
2018-01-10 16:01 DurtyFree Assigned To => DurtyFree
2018-01-10 16:01 DurtyFree Status new => resolved
2018-01-10 16:01 DurtyFree Resolution open => fixed
2018-01-10 16:01 DurtyFree Note Added: 0001276